Home > LINUX and GNU > Freenas bge0 error. watchdog timeout

Freenas bge0 error. watchdog timeout

Just reference. This is from a article from Internet.

Currently I got a HP DL 120 in production with a HP NC107i PCIe Gigabit NIC (NetXtreme BCM5723) and FreeBSD 9.0-RELEASE #0 installed. At first those entries in /var/log/messages were ignored because everything was running smooth and the system seemed normal and stable:

bge0: watchdog timeout -- resetting
bge0: link state changed to DOWN
bge0: link state changed to UP

With increasing network load there were a few unusual latency peaks and finally the NIC shut down or the system was frozen (w/out any messages of course). I couldn’t figure that one out, it is a remote box w/out KVM access. After some research I found that In order to get rid of those messages you need to disable bge0 ASF driver features by adding

hw.bge.allow_asf="0"

to your /boot/loader.conf – and yes, you really need to reboot your machine since sysctl hw.bge.allow_asf=”0″ will fail with “sysctl: oid ‘hw.bge.allow_asf’ is read only”. Those messages are gone now and the system seems stable as it should be.

Have fun!

p.s.: edit 25th of June 2012: The system is stable, issue solved.

Advertisements
Categories: LINUX and GNU
  1. Paolo
    October 16, 2013 at 12:19 AM

    Do you use an HP Thin Client T5550 HSTNC-012-TC for this?

  2. brandon gabert
    December 4, 2014 at 12:13 AM

    This problem has been bothering me for the better part of year, thanks for the informative post

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: